Reports of Latency
Incident Report for Nexternal
Resolved
We have fixed the issue that was causing latency in our network. Traffic is flowing normally.
Posted May 17, 2021 - 08:40 PDT
Identified
We have identified the problem and our team is working diligently to fix the issue. Traffic appears to be flowing normally now.
Posted May 17, 2021 - 07:13 PDT
Investigating
We are currently investigating reports of latency with our TC Connect and Amazon Marketplace services.
Posted May 17, 2021 - 06:30 PDT
This incident affected: Transaction Manager and Amazon.