Duplicate transactions
Incident Report for Nexternal
Resolved
This issue has been resolved.
Posted Sep 16, 2020 - 11:52 PDT
Update
This issue has been resolved. Orders placed between 10 AM - 2 PM EST may have been impacted. Please verify and delete any duplicate orders in Transaction Manager.
Posted Sep 16, 2020 - 11:50 PDT
Investigating
We’re currently investigating an issue that has caused duplicate orders from Nexternal to be sent to Transaction Manager. Not all customers are impacted. As we continue to investigate we ask that you login into Transaction Manager and review your Nexternal orders and delete any duplicate transactions.
Posted Sep 16, 2020 - 11:34 PDT
This incident affected: Transaction Manager and Amazon.