Phone system outage
Incident Report for Nexternal
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 24, 2019 - 13:01 PDT
Investigating
We are experiencing a phone system outage on our US phone numbers. All other systems are functioning. Account managers may continue to be reached via email or the help desk.
Posted 4 months ago. Jun 24, 2019 - 08:08 PDT