Latency
Incident Report for Nexternal
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 10, 2018 - 19:30 PDT
Investigating
We are currently investigating latency and performance issues in storefronts.
Posted 4 months ago. Jul 10, 2018 - 19:22 PDT
This incident affected: Online Catalogs.